[package] update owfs to 2.7p13, fix dependencies (#4476)
[openwrt/svn-archive/archive.git] / utils / setserial / Makefile
index 2d3d18bb4ca010c8aaa5cf5a9f517cbae83daf74..7c5574e672947e3314b650c5fbb85745a819a2eb 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,6 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/setserial
 PKG_MD5SUM:=c4867d72c41564318e0107745eb7a0f2
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -25,27 +24,30 @@ define Package/setserial
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Serial port configuration utility
-  DESCRIPTION:=\
-       setserial  is a program designed to set and/or report the \\\
-       configuration information associated with a serial port. This \\\
-       information  includes what I/O port and IRQ a particular \\\
-       serial port is using, and whether or not the break key should \\\
-       be interpreted as the Secure Attention Key, and so on.
   URL:=http://setserial.sourceforge.net/
+  SUBMENU:=terminal
+endef
+
+define Package/setserial/description
+       setserial is a program designed to set and/or report the 
+       configuration information associated with a serial port. This 
+       information includes what I/O port and IRQ a particular 
+       serial port is using, and whether or not the break key should 
+       be interpreted as the Secure Attention Key, and so on.
 endef
 
 # uses GNU configure
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               all
+               setserial
 endef
 
 define Package/setserial/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/setserial $(1)/usr/sbin/
-       install -d -m0755 $(1)/etc/init.d
-       install -m0755 ./files/serial.init $(1)/etc/init.d/setserial
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/setserial $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/serial.init $(1)/etc/init.d/setserial
 endef
 
 $(eval $(call BuildPackage,setserial))