packages: add missing conffiles define
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index 69494bebb17d1e67eb8b10db0a8f2141c7249fc6..1711b917814a299ef6c853e28e17b0d1e259cacb 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,56 +8,85 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.38
-PKG_RELEASE:=1
+PKG_VERSION:=5.40
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=a282846532ecbd6b4a28072373b3a70b
+PKG_MD5SUM:=0f0be0239914ad87830a4fff594bda5b
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/smartmontools
+define Package/smartmontools/Default
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+uclibcxx
-  TITLE:=S.M.A.R.T Monitoring Tool
+  TITLE:=S.M.A.R.T Monitoring
   URL:=http://smartmontools.sourceforge.net/
 endef
 
+define Package/smartmontools
+  $(call Package/smartmontools/Default)
+  TITLE+= Tool
+endef
+
 define Package/smartmontools/description
-       smartmontools contains utility programs (smartctl, smartd) to
-       control/monitor storage systems using the Self-Monitoring, Analysis
-       and Reporting Technology System (S.M.A.R.T.) built into most modern
-       ATA and SCSI disks. It is derived from smartsuite.
+  smartmontools contains utility programs (smartctl) to
+  control/monitor storage systems using the Self-Monitoring, Analysis
+  and Reporting Technology System (S.M.A.R.T.) built into most modern
+  ATA and SCSI disks. It is derived from smartsuite.
+endef
+
+define Package/smartd
+  $(call Package/smartmontools/Default)
+  DEPENDS+= +rsync
+  TITLE+= Daemon
+endef
+
+define Package/smartd/description
+  smartmontools contains utility programs (smartd) to
+  control/monitor storage systems using the Self-Monitoring, Analysis
+  and Reporting Technology System (S.M.A.R.T.) built into most modern
+  ATA and SCSI disks. It is derived from smartsuite.
 endef
 
 # uses GNU configure
 
-define Build/Configure 
-       (cd $(PKG_BUILD_DIR); ./autogen.sh );
-       $(call Build/Configure/Default,, \
-               ac_libc_have_working_snprintf=yes \
-               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
-               LDFLAGS="$$$$LDFLAGS" \
-               LIBS="-nodefaultlibs -luClibc++ -lm $(LIBGCC_S) -lc" \
-       )
+CONFIGURE_VARS += \
+       CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
+       CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
+       LDFLAGS="$$$$LDFLAGS" \
+       LIBS="-nodefaultlibs -luClibc++ -lm $(LIBGCC_S) -lc" \
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
+               ./autogen.sh \
+       );
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
+               LD="$(TARGET_CXX)"
 endef
 
 define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/smartctl $(1)/usr/sbin/
+endef
+
+define Package/smartd/install
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/smartd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
+       $(INSTALL_DATA) ./files/smartd.conf $(1)/etc/
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
+define Package/smartd/conffiles
+/etc/smartd.conf
+endef
+
 $(eval $(call BuildPackage,smartmontools))
+$(eval $(call BuildPackage,smartd))