smartmontools: Made the init script executable on installation
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index c35d2d71b246134778f52ab50df7da0d77a4b58d..44f3190c89d3722fcd88fe1ec334a3f6fd43c844 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
 PKG_VERSION:=5.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
@@ -55,7 +55,7 @@ define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/smartd.init $(1)/etc/init.d/smartd
+       $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
 $(eval $(call BuildPackage,smartmontools))