utils/smartmontools: update package to version 5.40 (closes #8116)
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index 5f3a07b38eb5d331b102c2d33008403e9c8e2b43..5b98d58e9c623e01426d76f8eb2c6b898531ddc1 100644 (file)
@@ -1,52 +1,61 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.37
-PKG_RELEASE:=2
+PKG_VERSION:=5.40
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_MD5SUM:=0f0be0239914ad87830a4fff594bda5b
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/smartmontools
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libstdcpp
+  DEPENDS:=+uclibcxx
   TITLE:=S.M.A.R.T Monitoring Tool
   URL:=http://smartmontools.sourceforge.net/
 endef
 
 define Package/smartmontools/description
-       smartmontools contains utility programs (smartctl, smartd) to 
-       control/monitor storage systems using the Self-Monitoring, Analysis 
-       and Reporting Technology System (S.M.A.R.T.) built into most modern 
+       smartmontools contains utility programs (smartctl, smartd) to
+       control/monitor storage systems using the Self-Monitoring, Analysis
+       and Reporting Technology System (S.M.A.R.T.) built into most modern
        ATA and SCSI disks. It is derived from smartsuite.
 endef
 
 # uses GNU configure
 
 define Build/Configure 
-       (cd $(PKG_BUILD_DIR); ./autogen.sh );
+       (cd $(PKG_BUILD_DIR); \
+       ./autogen.sh \
+       ./configure \
+               CC="$(TARGET_CC)" \
+               CXX="$(TARGET_CXX)" \
+               CPP="$(TARGET_CPP)" \
+               CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++"  \
+               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
+               LDFLAGS="$$$$LDFLAGS" \
+               LIBS="-nodefaultlibs -luClibc++ -lm $(LIBGCC_S) -lc" \
+               --prefix=/usr \
+               --build=$(GNU_BUILD_NAME) \
+               --host=$(GNU_HOST_NAME) \
+               --target=$(GNU_TARGET_NAME) \
+       );
        $(call Build/Configure/Default,, \
-       ac_libc_have_working_snprintf=yes \
        )
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
+       $(MAKE) -C $(PKG_BUILD_DIR) 
 endef
 
 define Package/smartmontools/install
@@ -60,7 +69,3 @@ define Package/smartmontools/install
 endef
 
 $(eval $(call BuildPackage,smartmontools))
-
-$(eval $(call RequireCommand,automake-1.9, \
-       $(PKG_NAME) requires automake 1.9 or compatible. \
-))