remove useless xorg macros patch
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index e9b5b05d1144c3b748794176e245cf31b56bd2de..71fe9693cbd664a3088ed9dd0443f0d186acc100 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
 PKG_VERSION:=5.37
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/smartmontools
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libstdcpp
   TITLE:=S.M.A.R.T Monitoring Tool
   DESCRIPTION:=\
        smartmontools contains utility programs (smartctl, smartd) to \\\
@@ -54,11 +55,11 @@ define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/smartd.init $(1)/etc/init.d/smartd
+       $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
 $(eval $(call BuildPackage,smartmontools))
 
-$(eval $(call RequireCommand,automake, \
-       $(PKG_NAME) requires automake. \
+$(eval $(call RequireCommand,automake-1.9, \
+       $(PKG_NAME) requires automake 1.9 or compatible. \
 ))