[packages] copy/modify openntpd's postinst code for ntpd, ntpdate and ntp-utils
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index 479cfe473ad38e880404cc915b3a7c9e2251bf3a..cc3ac6f0a5869cdfdf3d044560448207c98f918b 100644 (file)
@@ -4,18 +4,17 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
-PKG_VERSION:=5.36
-PKG_RELEASE:=1
+PKG_VERSION:=5.37
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
-PKG_MD5SUM:=2e424f2d35efa38a29ebca419c1dbe3c
-PKG_CAT:=zcat
+PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -24,15 +23,18 @@ include $(INCLUDE_DIR)/package.mk
 define Package/smartmontools
   SECTION:=utils
   CATEGORY:=Utilities
+  DEPENDS:=+libstdcpp
   TITLE:=S.M.A.R.T Monitoring Tool
-  DESCRIPTION:=\
-       smartmontools contains utility programs (smartctl, smartd) to \\\
-       control/monitor storage systems using the Self-Monitoring, Analysis \\\
-       and Reporting Technology System (S.M.A.R.T.) built into most modern \\\
-       ATA and SCSI disks. It is derived from smartsuite.
   URL:=http://smartmontools.sourceforge.net/
 endef
 
+define Package/smartmontools/description
+       smartmontools contains utility programs (smartctl, smartd) to 
+       control/monitor storage systems using the Self-Monitoring, Analysis 
+       and Reporting Technology System (S.M.A.R.T.) built into most modern 
+       ATA and SCSI disks. It is derived from smartsuite.
+endef
+
 # uses GNU configure
 
 define Build/Configure 
@@ -54,7 +56,7 @@ define Package/smartmontools/install
        $(INSTALL_DIR) $(1)/etc
        $(INSTALL_DATA) ./files/smartd.conf $(1)/etc
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/smartd.init $(1)/etc/init.d/smartd
+       $(INSTALL_BIN) ./files/smartd.init $(1)/etc/init.d/smartd
 endef
 
 $(eval $(call BuildPackage,smartmontools))