[packages] copy/modify openntpd's postinst code for ntpd, ntpdate and ntp-utils
[openwrt/svn-archive/archive.git] / utils / smartmontools / Makefile
index 71fe9693cbd664a3088ed9dd0443f0d186acc100..cc3ac6f0a5869cdfdf3d044560448207c98f918b 100644 (file)
@@ -15,7 +15,6 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
 PKG_MD5SUM:=4ab3668b7d1362ce923f64a211e0e568
-PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -26,14 +25,16 @@ define Package/smartmontools
   CATEGORY:=Utilities
   DEPENDS:=+libstdcpp
   TITLE:=S.M.A.R.T Monitoring Tool
-  DESCRIPTION:=\
-       smartmontools contains utility programs (smartctl, smartd) to \\\
-       control/monitor storage systems using the Self-Monitoring, Analysis \\\
-       and Reporting Technology System (S.M.A.R.T.) built into most modern \\\
-       ATA and SCSI disks. It is derived from smartsuite.
   URL:=http://smartmontools.sourceforge.net/
 endef
 
+define Package/smartmontools/description
+       smartmontools contains utility programs (smartctl, smartd) to 
+       control/monitor storage systems using the Self-Monitoring, Analysis 
+       and Reporting Technology System (S.M.A.R.T.) built into most modern 
+       ATA and SCSI disks. It is derived from smartsuite.
+endef
+
 # uses GNU configure
 
 define Build/Configure 
@@ -59,7 +60,3 @@ define Package/smartmontools/install
 endef
 
 $(eval $(call BuildPackage,smartmontools))
-
-$(eval $(call RequireCommand,automake-1.9, \
-       $(PKG_NAME) requires automake 1.9 or compatible. \
-))