[packages] strace: call the install target, re-remove the obsolete 2.6.21 test, remov...
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index 6e93e233e144a495a57f9ff76ee3b53db7dfb5d8..4caa2e42f325ee389742430165ad3374470c2067 100644 (file)
@@ -1,22 +1,30 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.14
-PKG_RELEASE:=1
+PKG_RELEASE:=3
+
+ifeq ($(CONFIG_LINUX_2_6_25),y)
+  PKG_VERSION:=4.5.16
+  PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
+  PATCH_DIR:=patches-4.5.16
+else
+  PKG_VERSION:=4.5.19
+  PKG_MD5SUM:=2415e435d61e40315a298c80aced0cda
+endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/strace
-PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,21 +36,19 @@ define Package/strace
 endef
 
 define Package/strace/description
-       A useful diagnostic, instructional, and debugging tool. 
-       Allows you to track what system calls a program makes while it is 
-       running.
+A useful diagnostic, instructional, and debugging tool. Allows you to track what
+system calls a program makes while it is running.
 endef
 
-# uses GNU configure
+CONFIGURE_VARS += \
+       ac_cv_header_linux_netlink_h=yes
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               CC="$(TARGET_CC)"
-endef
+TARGET_CFLAGS += \
+       -I$(LINUX_DIR)/include
 
 define Package/strace/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,strace))