Updated strace package to version 4.5.18 - dirent.h changed in the kernel sources...
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index 6e93e233e144a495a57f9ff76ee3b53db7dfb5d8..7044ee6f7708514aa8f08a3f9b6c73de766a1a86 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.14
-PKG_RELEASE:=1
+PKG_VERSION:=4.5.18
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/strace
-PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,13 +28,11 @@ define Package/strace
 endef
 
 define Package/strace/description
-       A useful diagnostic, instructional, and debugging tool. 
-       Allows you to track what system calls a program makes while it is 
+       A useful diagnostic, instructional, and debugging tool.
+       Allows you to track what system calls a program makes while it is
        running.
 endef
 
-# uses GNU configure
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)"
@@ -42,7 +40,7 @@ endef
 
 define Package/strace/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,strace))