Updated strace package to version 4.5.18 - dirent.h changed in the kernel sources...
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index b3a9d90e78c8d8be40a28aee193ca6e5a5e04ca7..7044ee6f7708514aa8f08a3f9b6c73de766a1a86 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.14
-PKG_RELEASE:=1
+PKG_VERSION:=4.5.18
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/strace
-PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,14 +24,14 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
-  DESCRIPTION:=\
-       A useful diagnostic, instructional, and debugging tool. \\\
-       Allows you to track what system calls a program makes while it is \\\
-       running.
   URL:=http://strace.sourceforge.net/
 endef
 
-# uses GNU configure
+define Package/strace/description
+       A useful diagnostic, instructional, and debugging tool.
+       Allows you to track what system calls a program makes while it is
+       running.
+endef
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -40,8 +39,8 @@ define Build/Compile
 endef
 
 define Package/strace/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,strace))