Fix scponly compilation (#1982)
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index c85fa1134d61db807249a2dca4f82dd8b2804984..af5a7082be503f3db19173ecbd67f81ed2763db5 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.11
+PKG_VERSION:=4.5.14
 PKG_RELEASE:=1
-PKG_MD5SUM:=28335e15c83456a3db055a0a0efcb4fe
 
-PKG_SOURCE_URL:=@SF/strace
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/strace
+PKG_MD5SUM:=09bcd5d00ece28f8154dec11cadfce3c
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -25,15 +25,14 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
-  DESCRIPTION:=A useful diagnostic, instructional, and debugging tool. \\\
-    Allows you to track what system calls a program makes while it is \\\
-    running.
+  DESCRIPTION:=\
+       A useful diagnostic, instructional, and debugging tool. \\\
+       Allows you to track what system calls a program makes while it is \\\
+       running.
   URL:=http://strace.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default)
-endef
+# uses GNU configure
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -41,8 +40,8 @@ define Build/Compile
 endef
 
 define Package/strace/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,strace))