Add avr32 support for strace
[openwrt/svn-archive/archive.git] / utils / strace / Makefile
index 9c297fdac5c23e9f455944111fe869f412b1c8c0..df6ddb8574d31af81883143eb36777ad097be08f 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_VERSION:=4.5.11
-PKG_RELEASE:=1
-PKG_MD5SUM:=28335e15c83456a3db055a0a0efcb4fe
+PKG_VERSION:=4.5.16
+PKG_RELEASE:=2
 
-PKG_SOURCE_URL:=@SF/strace
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_CAT:=bzcat
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,39 +24,13 @@ define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=System call tracer
-  DESCRIPTION:=A useful diagnostic, instructional, and debugging tool. \\\
-    Allows you to track what system calls a program makes while it is \\\
-    running.
   URL:=http://strace.sourceforge.net/
 endef
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_NLS) \
-                       $(DISABLE_LARGEFILE) \
-       );
+define Package/strace/description
+       A useful diagnostic, instructional, and debugging tool.
+       Allows you to track what system calls a program makes while it is
+       running.
 endef
 
 define Build/Compile
@@ -66,8 +39,8 @@ define Build/Compile
 endef
 
 define Package/strace/install
-       install -m0755 -d $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/strace $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,strace))