[package] update stress to 1.0.2 (#6451)
[openwrt/svn-archive/archive.git] / utils / stress / Makefile
index ab2c03c54bbfb1e166d22998a59fa4be77ce7fd7..fe5f9f93f5e51dbbfc97a8a24a747bc315939eae 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stress
-PKG_VERSION:=0.18.9
+PKG_VERSION:=1.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://weather.ou.edu/~apw/projects/stress/
-PKG_MD5SUM:=e6fba31fbac8d0a1b359c7e25cba8e3f
+PKG_MD5SUM:=ad53eb802150bda8f898be9ebf3b4b36
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -28,7 +28,8 @@ define Package/stress
 endef
 
 define Package/stress/description
-       stress is a simple tool that imposes certain types of compute \ stress on UNIX-like operating systems.
+       stress is a simple tool that imposes certain types of compute \ stress
+       on UNIX-like operating systems.
 endef
 
 CONFIGURE_ARGS += \
@@ -38,8 +39,8 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
 define Package/stress/install
-       install -d -m0755 $(1)/usr/bin
-       install -m0755 $(PKG_BUILD_DIR)/src/stress $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stress $(1)/usr/bin
 endef
 
 $(eval $(call BuildPackage,stress))