[vim] enable multibyte feature in vim-full package
[openwrt/svn-archive/archive.git] / utils / sysstat / Makefile
index dd0a5bcc07e395df13c61b80b728b43d64e1b61a..4be0bb121794ee25dee558e51a2d9d84cbf5d454 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sysstat
-PKG_VERSION:=8.0.1
-PKG_RELEASE:=2
+PKG_VERSION:=9.0.6
+PKG_RELEASE:=1
 
-PKG_SOURCE:=sysstat-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://perso.orange.fr/sebastien.godard
-PKG_MD5SUM:=10369aeb42290f0141e685d33cdac658
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://pagesperso-orange.fr/sebastien.godard
+PKG_MD5SUM:=e069daf192d259de905d7f8cdd85dc4e
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -21,11 +23,12 @@ define Package/sysstat
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Sysstat performance monitoring tools
-  URL:=http://perso.orange.fr/sebastien.godard/index.html
+  URL:=http://pagesperso-orange.fr/sebastien.godard/index.html
 endef
 
 define Package/sysstat/description
-  The sysstat utilities are a collection of performance monitoring tools for Linux. These include sar, sadf, mpstat, iostat, pidstat and sa tools.
+  The sysstat utilities are a collection of performance monitoring tools for
+  Linux. These include sar, sadf, mpstat, iostat, pidstat and sa tools.
 endef
 
 define Package/sysstat/conffiles
@@ -33,22 +36,22 @@ define Package/sysstat/conffiles
 /etc/sysstat/config
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               sa_lib_dir="/usr/lib/sysstat" \
-               sa_dir="/var/log/sysstat" \
-               conf_dir="/etc/sysstat" \
-       )
-endef
+CONFIGURE_VARS+= \
+       sa_lib_dir="/usr/lib/sysstat" \
+       sa_dir="/var/log/sysstat" \
+       conf_dir="/etc/sysstat" \
+
+CONFIGURE_ARGS+= \
+       --disable-documentation \
 
 define Package/sysstat/install
        $(INSTALL_DIR) $(1)/usr/lib/sysstat
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/{sadc,sa1,sa2} $(1)/usr/lib/sysstat
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/sysstat/{sadc,sa1,sa2} $(1)/usr/lib/sysstat/
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/{sar,sadf,iostat,mpstat} $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/{sar,sadf,iostat,mpstat,pidstat} $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/etc/sysstat
-       $(CP) $(PKG_BUILD_DIR)/sysstat.ioconf $(1)/etc/sysstat
-       $(CP) ./files/config $(1)/etc/sysstat/config
+       $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/sysstat/sysstat.ioconf $(1)/etc/sysstat/
+       $(INSTALL_CONF) ./files/config $(1)/etc/sysstat/config
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/sysstat.init $(1)/etc/init.d/sysstat
 endef