[packages_10.03.1] collectd: backport r29404
[openwrt/svn-archive/archive.git] / utils / tmux / Makefile
index 160a8dc1ec85e710f5419b0c6ae699b945dbf417..eaa45bbd74f4dfe2a3533f8012e1a3b3a2a28d30 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,14 +7,15 @@
 
 include $(TOPDIR)/rules.mk
 
-
 PKG_NAME:=tmux
-PKG_VERSION:=1.1
+PKG_VERSION:=1.4
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/tmux
-PKG_MD5SUM:=faf2fc52ac3ae63d899f6fece2c112cd
+PKG_MD5SUM:=0bfc7dd9a5bab192406167589c716a21
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,25 +23,21 @@ define Package/tmux
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=Terminal multiplexer
-  DEPENDS:=+libncurses
-  URL:=http://tmux.sourceforge.net
+  DEPENDS:=+libncurses +libevent +libpthread
+  URL:=http://tmux.sourceforge.net/
 endef
 
 define Package/tmux/description
   tmux is a modern, BSD-licensed alternative to GNU screen.
 endef
 
-define Build/Compile
-       CC="$(TARGET_CC)" \
-       CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
-       LDFLAGS="$(TARGET_LDFLAGS)" \
+MAKE_FLAGS += \
+       PREFIX="/usr" \
        TMUX_PLATFORM="Linux" \
-       $(MAKE) -C $(PKG_BUILD_DIR) all
-endef
 
 define Package/tmux/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/tmux $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tmux $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,tmux))