packages: Use $(CP) instead of $(INSTALL_BIN) for binaries.
[openwrt/svn-archive/archive.git] / utils / unzip / Makefile
index 43c4cdede5f839c9f6049e2a60c021bbf0a09308..ed338dcc054989d619f01c404389feeafbb901df 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id
+# $Id$ 
 
 include $(TOPDIR)/rules.mk
 
@@ -27,12 +27,15 @@ define Package/unzip
   CATEGORY:=Utilities
   DEPENDS:=
   TITLE:=De-archiver for .zip files
-  DESCRIPTION:=\
-       InfoZIP's unzip program. With the exception of multi-volume archives \\\
-       (ie, .ZIP files that are split across several disks using PKZIP's /& option), \\\
-       this can handle any file produced either by PKZIP, or the corresponding \\\
-       InfoZIP zip program.
   URL:=http://infozip.sourceforge.net/Zip.html
+  SUBMENU:=compression
+endef
+
+define Package/unzip/description
+       InfoZIP's unzip program. With the exception of multi-volume archives 
+       (ie, .ZIP files that are split across several disks using PKZIP's /& option), 
+       this can handle any file produced either by PKZIP, or the corresponding 
+       InfoZIP zip program.
 endef
 
 define Build/Configure
@@ -50,7 +53,7 @@ endef
 
 define Package/unzip/install   
        $(INSTALL_DIR) $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,unzip))