new upstream release
[openwrt/svn-archive/archive.git] / utils / usb-modeswitch / Makefile
index 2266498cbe07b422684930098260d4f535ddc168..2dc0e2d41c469a1557ccc9329a3e5b13f866b051 100644 (file)
@@ -1,21 +1,19 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usb_modeswitch
-PKG_VERSION:=0.9.5
+PKG_VERSION:=1.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.draisberghof.de/usb_modeswitch
-PKG_CAT:=bzcat
-PKG_MD5SUM:=d84961e86f0c3578f83448a3fb01ef52
+PKG_MD5SUM:=4f896ed631f9be0338df9c5a2145ef82
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,6 +22,7 @@ define Package/usb-modeswitch
   CATEGORY:=Utilities
   DEPENDS:=+libusb
   TITLE:=USB ModeSwitch
+  URL:=http://www.draisberghof.de/usb_modeswitch/
 endef
 
 define Package/usb-modeswitch/description
@@ -32,9 +31,8 @@ define Package/usb-modeswitch/description
 endef
 
 define Build/Compile
-       "$(TARGET_CC)" $(TARGET_CFLAGS) -I $(STAGING_DIR)/include/ \
-               -I $(STAGING_DIR)/usr/include/ -L $(STAGING_DIR)/lib/ \
-               -L $(STAGING_DIR)/usr/lib/ -lusb \
+       "$(TARGET_CC)" $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS) \
+               -lusb \
                -o $(PKG_BUILD_DIR)/usb_modeswitch-OpenWrt \
                                $(PKG_BUILD_DIR)/usb_modeswitch.c
 endef