add new kismet version, thanks dragorn
[openwrt/svn-archive/archive.git] / utils / usbutils / Makefile
index 0b3f2d95a5d49ea1fed294f2d234d873234646bd..672eb6354d66a30d47a5e63c261252c9d2b493bc 100644 (file)
@@ -30,12 +30,7 @@ define Package/usbutils
   URL:=http://linux-usb.sourceforge.net/
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-       )
-endef
+# uses GNU configure
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -44,9 +39,9 @@ define Build/Compile
 endef
 
 define Package/usbutils/install
-       install -d -m0755 $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
-       install -d -m0755 $(1)/usr/share
+       $(INSTALL_DIR) $(1)/usr/share
        $(CP) $(PKG_INSTALL_DIR)/usr/share/usb.ids $(1)/usr/share/
 endef