[package] update loop-aes to 3.2h (#6277)
[openwrt/svn-archive/archive.git] / utils / usbutils / Makefile
index 122050e9a88c9bf66986fd9d37aa9b33b04905a7..814d8f2e4f7dd92d2b7cdf6b3a257c65fa94e771 100644 (file)
@@ -1,37 +1,34 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbutils
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=usbutils
-PKG_VERSION:=0.73
+PKG_VERSION:=0.86
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-usb
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/linux-usb
-PKG_MD5SUM:=ee345fe605ffcfce843dae4aed81122b
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=34979f675d2bcb3e1b45012fa830a53f
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/usbutils
   SECTION:=utils
   CATEGORY:=Utilities
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/usbutils
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libusb
+  DEPENDS:=+libusb +zlib
   TITLE:=USB devices listing utilities
   URL:=http://linux-usb.sourceforge.net/
 endef
 
 define Package/usbutils/postinst
 #!/bin/sh
   TITLE:=USB devices listing utilities
   URL:=http://linux-usb.sourceforge.net/
 endef
 
 define Package/usbutils/postinst
 #!/bin/sh
-$${IPKG_INSTROOT}/usr/sbin/update-usbids.sh
+(cd $${IPKG_INSTROOT}/usr/share; $${IPKG_INSTROOT}/usr/sbin/update-usbids.sh)
+exit 0
 endef
 
 # uses GNU configure
 endef
 
 # uses GNU configure
@@ -43,11 +40,13 @@ define Build/Compile
 endef
 
 define Package/usbutils/install
 endef
 
 define Package/usbutils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/usb-devices $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
-       $(CP) $(PKG_BUILD_DIR)/update-usbids.sh $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/lsusb $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/update-usbids.sh $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/usr/share
        $(INSTALL_DIR) $(1)/usr/share
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/usb.ids $(1)/usr/share/
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/usb.ids.gz $(1)/usr/share/
 endef
 
 $(eval $(call BuildPackage,usbutils))
 endef
 
 $(eval $(call BuildPackage,usbutils))