Change the name to match patch convention
[openwrt/svn-archive/archive.git] / utils / vim / Makefile
index f5e0d4d2a42a4c5ca117a6084406db61bc3cdf6a..0016d27bf626e477b453f6354fb17eaf3db67c27 100644 (file)
@@ -14,7 +14,7 @@ PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_MD5SUM:=
+PKG_MD5SUM:=89ab05bb5cd39eeb9e259503436c11ed
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -26,31 +26,26 @@ define Package/vim
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=VI Improved
-  DESCRIPTION:=An improved version of VI.
-  URL:=http://www.vim.org
+  URL:=http://www.vim.org/
 endef
 
 define Build/Configure
-$(call Build/Configure/Default,--enable-min-features \
-                       --disable-gui \
-                       --without-x \
-                       --disable-multibyte \
-                       --disable-cscope \
-                       --disable-gpm \
-                       --with-tlib=ncurses,ac_cv_c_bigendian=no \
-                       ac_cv_sizeof_off_t=8 \
-                       ac_cv_sizeof_int=4)
-endef
-
-define Build/Compile
-$(call Build/Compile/Default,CC="$(TARGET_CC)")
+       $(call Build/Configure/Default, \
+               --enable-min-features \
+               --disable-gui \
+               --without-x \
+               --disable-multibyte \
+               --disable-cscope \
+               --disable-gpm \
+               --with-tlib=ncurses \
+       )
 endef
 
 define Package/vim/install     
-       mkdir -p $(1)/usr/bin
-       mkdir -p $(1)//usr/share/vim
-       $(CP) ./files/vimrc $(1)//usr/share/vim
+       $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/share/vim
+       $(CP) ./files/vimrc $(1)/usr/share/vim/
 endef
 
 $(eval $(call BuildPackage,vim))