add mutella (thanks to olli)
[openwrt/svn-archive/archive.git] / utils / vim / Makefile
index aa6f526f61b4329e4abf77a6810bd46d77a0e266..cdd80e2a0bf5d888da1393f94e954377b154c576 100644 (file)
@@ -9,15 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vim
-PKG_VERSION:=5.8
-PKG_RELEASE:=1
+PKG_VERSION:=7.1
+PKG_RELEASE:=2
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_MD5SUM:=
-PKG_CAT:=zcat
+PKG_MD5SUM:=44c6b4914f38d6f9aa959640b89da329
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)71
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,28 +24,30 @@ define Package/vim
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
-  TITLE:=VI Improved
-  DESCRIPTION:=An improved version of VI.
-  URL:=http://www.vim.org
+  TITLE:=Vi IMproved - enhanced vi editor
+  DESCRIPTION:=\
+       Vim is an almost compatible version of the UNIX editor Vi.
+  URL:=http://www.vim.org/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--enable-min-features \
-                       --disable-gui \
-                       --without-x \
-                       --disable-multibyte \
-                       --disable-cscope \
-                       --disable-gpm \
-                       --with-tlib=ncurses,ac_cv_c_bigendian=no \
-                       ac_cv_sizeof_off_t=8 \
-                       ac_cv_sizeof_int=4)
-endef
+CONFIGURE_ARGS += \
+       --disable-gui \
+       --enable-gui=none \
+       --disable-gtktest \
+       --disable-xim \
+       --with-features=tiny \
+       --without-x \
+       --disable-multibyte \
+       --disable-netbeans \
+       --disable-cscope \
+       --disable-gpm \
+       --with-tlib=ncurses
 
 define Package/vim/install     
-       mkdir -p $(1)/usr/bin
-       mkdir -p $(1)//usr/share/vim
-       $(CP) ./files/vimrc $(1)//usr/share/vim
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/share/vim
+       $(INSTALL_CONF) ./files/vimrc $(1)/usr/share/vim/
 endef
 
 $(eval $(call BuildPackage,vim))