libexpat: avr32 compile fix
[openwrt/svn-archive/archive.git] / utils / vim / Makefile
index 0016d27bf626e477b453f6354fb17eaf3db67c27..dd2f6b4bcbd4bbfc315621539f69a8f1f74d2cbc 100644 (file)
@@ -9,15 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vim
-PKG_VERSION:=5.8
-PKG_RELEASE:=1
+PKG_VERSION:=7.1
+PKG_RELEASE:=2
 
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_MD5SUM:=89ab05bb5cd39eeb9e259503436c11ed
-PKG_CAT:=zcat
+PKG_MD5SUM:=44c6b4914f38d6f9aa959640b89da329
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)71
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,27 +24,32 @@ define Package/vim
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
-  TITLE:=VI Improved
+  TITLE:=Vi IMproved - enhanced vi editor
   URL:=http://www.vim.org/
+  SUBMENU:=Editors
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-min-features \
-               --disable-gui \
-               --without-x \
-               --disable-multibyte \
-               --disable-cscope \
-               --disable-gpm \
-               --with-tlib=ncurses \
-       )
+define Package/vim/description
+       Vim is an almost compatible version of the UNIX editor Vi.
 endef
 
+CONFIGURE_ARGS += \
+       --disable-gui \
+       --disable-gtktest \
+       --disable-xim \
+       --with-features=tiny \
+       --without-x \
+       --disable-multibyte \
+       --disable-netbeans \
+       --disable-cscope \
+       --disable-gpm \
+       --with-tlib=ncurses
+
 define Package/vim/install     
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share/vim
-       $(CP) ./files/vimrc $(1)/usr/share/vim/
+       $(INSTALL_CONF) ./files/vimrc $(1)/usr/share/vim/
 endef
 
 $(eval $(call BuildPackage,vim))