[packages] restorefactory: cleanup code (closes: #7327)
[openwrt/svn-archive/archive.git] / utils / wx200d / Makefile
index 25ced23d35b67cf5d2dca3390cfaf32da175538c..c33d071188839beb3ae3d3cd4d31cfd5ac4e58e4 100644 (file)
@@ -4,21 +4,18 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wx200d
 PKG_VERSION:=1.3
 PKG_RELEASE:=1
-PKG_MD5SUM:=0f90c099dddcdd46ac568d707822ec4c
 
-PKG_SOURCE_URL:=@SF/wx200d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=@SF/wx200d
+PKG_MD5SUM:=0f90c099dddcdd46ac568d707822ec4c
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,31 +24,28 @@ define Package/wx200d
   CATEGORY:=Utilities
   DEPENDS:=+libpq
   TITLE:=weather station data collector
-  DESCRIPTION:=wx200d is a weather station data collector and server daemon\\\
-  for the WX200, WM918, WMR918 and WMR968 weather station\\\
-  hardware.\\\
   URL:=http://wx200d.sourceforge.net/
 endef
 
-define Build/Configure
-$(call Build/Configure/Default,--without-libiconv-prefix \
-                       --without-libintl-prefix)
+define Package/wx200d/description
+       wx200d is a weather station data collector and server daemon 
+       for the WX200, WM918, WMR918 and WMR968 weather station 
+       hardware.
 endef
 
-define Build/Compile
-$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install)
-endef
+# uses GNU configure
 
-define Package/wx200d/install  
-       install -d -m0755 $(1)/usr/bin
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/wx200 \
+define Package/wx200d/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP)   $(PKG_INSTALL_DIR)/usr/bin/wx200 \
                $(PKG_INSTALL_DIR)/usr/bin/wxstdout \
                $(PKG_INSTALL_DIR)/usr/bin/wxfilter \
-               $(PKG_INSTALL_DIR)/usr/bin/wxdebug $(1)/usr/bin/
-       install -d -m0755 $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/wx200d \
-               $(PKG_INSTALL_DIR)/usr/sbin/wxread $(1)/usr/sbin/
+               $(PKG_INSTALL_DIR)/usr/bin/wxdebug \
+               $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin/
+       $(CP)   $(PKG_INSTALL_DIR)/usr/sbin/wx200d \
+               $(PKG_INSTALL_DIR)/usr/sbin/wxread \
+               $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,wx200d))