[packages] zile: Update to v2.3.9 (closes #5661)
[openwrt/svn-archive/archive.git] / utils / zile / Makefile
index c7b476dad10b53623adf7c980f39e2cf129a72b5..5485ffc994eb46c777f447905921b12480d7ff78 100644 (file)
@@ -1,22 +1,19 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zile
-PKG_VERSION:=2.2.37
+PKG_VERSION:=2.3.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/zile
-PKG_MD5SUM:=041e047ff293739166c9d17174645200
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=@GNU/zile
+PKG_MD5SUM:=51f2fb489b81d80f997644e872445370
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,21 +22,19 @@ define Package/zile
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=very small emacs-like editor
-  DESCRIPTION:=\
-       Zile is a small Emacs clone. Zile is a customizable, self-documenting \\\
-       real-time display editor. Zile was written to be as similar as possible \\\
-       to Emacs; every Emacs user should feel at home with Zile.
   URL:=http://zile.sourceforge.net
+  SUBMENU:=Editors
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               all
+define Package/zile/description
+       Zile is a small Emacs clone. Zile is a customizable, self-documenting
+       real-time display editor. Zile was written to be as similar as possible
+       to Emacs; every Emacs user should feel at home with Zile.
 endef
 
 define Package/zile/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,zile))