[packages] nvramtool: use the new repo, per http://www.coreboot.org/pipermail/coreboo...
[openwrt/svn-archive/archive.git] / utils / zile / Makefile
index 27b40827a03010c565ce1c058176fc2bdaf60db0..83f1a645adb04690ad6d732635feba1068a23373 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zile
-PKG_VERSION:=2.3.11
+PKG_VERSION:=2.3.15
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/zile
-PKG_MD5SUM:=eda8745c2681dd7bea478496c0178e90
+PKG_MD5SUM:=2d9cfab3a7776e5e218b439fbef862a0
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,7 +24,7 @@ define Package/zile
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=very small emacs-like editor
-  URL:=http://zile.sourceforge.net
+  URL:=http://www.gnu.org/software/zile/
   SUBMENU:=Editors
 endef
 
@@ -32,9 +34,12 @@ define Package/zile/description
        to Emacs; every Emacs user should feel at home with Zile.
 endef
 
+CONFIGURE_VARS += \
+       gl_cv_func_getopt_gnu=yes \
+
 define Package/zile/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,zile))