[packages] zile: update to 2.3.19
[openwrt/svn-archive/archive.git] / utils / zile / Makefile
index c7b476dad10b53623adf7c980f39e2cf129a72b5..aeb95110401da1dd2fb74c05f88f7bbbf8c62131 100644 (file)
@@ -1,22 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zile
-PKG_VERSION:=2.2.37
+PKG_VERSION:=2.3.19
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/zile
-PKG_MD5SUM:=041e047ff293739166c9d17174645200
+PKG_SOURCE_URL:=@GNU/zile
+PKG_MD5SUM:=c23096fc646bc4a906c24c1bbe4e29f6
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,21 +24,22 @@ define Package/zile
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=very small emacs-like editor
-  DESCRIPTION:=\
-       Zile is a small Emacs clone. Zile is a customizable, self-documenting \\\
-       real-time display editor. Zile was written to be as similar as possible \\\
-       to Emacs; every Emacs user should feel at home with Zile.
-  URL:=http://zile.sourceforge.net
+  URL:=http://www.gnu.org/software/zile/
+  SUBMENU:=Editors
 endef
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR)/src \
-               all
+define Package/zile/description
+       Zile is a small Emacs clone. Zile is a customizable, self-documenting
+       real-time display editor. Zile was written to be as similar as possible
+       to Emacs; every Emacs user should feel at home with Zile.
 endef
 
+CONFIGURE_VARS += \
+       gl_cv_func_getopt_gnu=yes \
+
 define Package/zile/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,zile))