[packages] zile: force getopt detection
[openwrt/svn-archive/archive.git] / utils / zile / Makefile
index 27b40827a03010c565ce1c058176fc2bdaf60db0..c47bdff2e000c8daabee317ba7e6b0f06e397760 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=zile
-PKG_VERSION:=2.3.11
+PKG_VERSION:=2.3.14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/zile
-PKG_MD5SUM:=eda8745c2681dd7bea478496c0178e90
+PKG_MD5SUM:=88322abbb8146f3c4e7bb31fa4d351c6
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,7 +22,7 @@ define Package/zile
   CATEGORY:=Utilities
   DEPENDS:=+libncurses
   TITLE:=very small emacs-like editor
-  URL:=http://zile.sourceforge.net
+  URL:=http://www.gnu.org/software/zile/
   SUBMENU:=Editors
 endef
 
@@ -32,6 +32,9 @@ define Package/zile/description
        to Emacs; every Emacs user should feel at home with Zile.
 endef
 
+CONFIGURE_VARS += \
+       gl_cv_func_getopt_gnu=yes \
+
 define Package/zile/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/