[package] downgrade nano to 2.0.9 (stable) (#4873)
[openwrt/svn-archive/archive.git] / utils / zip / Makefile
index c2fc9b007a460f5fbeb3a7e73b8851897d3af091..0468e83b12903a0599fe591abc053ce0b38c3e8d 100644 (file)
@@ -4,7 +4,7 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id
+# $Id$ 
 
 include $(TOPDIR)/rules.mk
 
@@ -16,9 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)232.zip
 PKG_SOURCE_URL:=@SF/infozip
 PKG_MD5SUM:=da947ed356e5fdb30ff4bc3dc7698f33
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
+PKG_UNPACK=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -27,12 +25,15 @@ define Package/zip
   CATEGORY:=Utilities
   DEPENDS:=
   TITLE:=Archiver for .zip files
-  DESCRIPTION:=\
-       This is InfoZIP's zip program. It produces files that are fully \\\
-       compatible with the popular PKZIP program; however, the command line \\\
-       options are not identical. In other words, the end result is the same, \\\
-       but the methods differ.
   URL:=http://infozip.sourceforge.net/Zip.html
+  SUBMENU:=compression
+endef
+
+define Package/zip/description
+       This is InfoZIP's zip program. It produces files that are fully 
+       compatible with the popular PKZIP program; however, the command line 
+       options are not identical. In other words, the end result is the same, 
+       but the methods differ.
 endef
 
 define Build/Configure
@@ -50,7 +51,7 @@ endef
 
 define Package/zip/install     
        $(INSTALL_DIR) $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,zip))