Add a patch for openssl to fix some breakage that happens when compiled with gcc...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 28 Jun 2007 21:09:44 +0000 (21:09 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 28 Jun 2007 21:09:44 +0000 (21:09 +0000)
commita068621a9db56f8244ec9a6966fa09d9949e7138
treeb3ff65f3b83d6639124c61ac9edffcecc4dbd32f
parentd99382d8ca418379983f1c37989e7a753a6894fb
Add a patch for openssl to fix some breakage that happens when compiled with gcc 4.2.0
Note: this does not cover all instances, but it will at least compile.

If the broken parts are reached at run time, the program will crash.
I wonder whose stupid idea it was to intentionally(!) make programs segfault when they hit something that *might* be unsafe to use.

Patch taken from http://www.mail-archive.com/openssl-dev@openssl.org/msg22667.html

SVN-Revision: 7764
package/openssl/patches/180-gcc_breakage.patch [new file with mode: 0644]