[lantiq] dgn3500 support with eeprom loading from sysfs
authorJohn Crispin <john@openwrt.org>
Sun, 27 May 2012 16:02:22 +0000 (16:02 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 27 May 2012 16:02:22 +0000 (16:02 +0000)
commitc7b12d4bf71798a5c66fd70dd55fdfb2c7bfb937
tree1e3cd6cc42d48bc53f408ceb721ad1f8c630f5e2
parent84a2ac91a5405b6d32e2d2bc5a21118a9aa3e892
[lantiq] dgn3500 support with eeprom loading from sysfs

WIFI eeprom:
As discussed, it is impossible for nand and spi flash platforms to have the eeprom data available from mtd. I suggested to load the eeprom from user-space. I've looked into regular firmware loading but this is only possible when using modules.  I've created a sysfs entry that allows reading and writing the eeprom data to the platform data. After loading the eeprom data I rely on pci-hotplug support to disable the bogus pci device and rescan the bus (with fixups and all). Because hotplug is not available, an init script is created that performs the copy from mtd to platform data. I think it is best to eventually move the sysfs functions to dev_wifi_athxk.c file, this would get rid of the external to the ath9k platform data.

SPI flash:
It seems that the spi-xway driver is not really working. It causes my kernel to crash in all sorts of ways. I added to bitbang SPI to be able to the calibration data mention above.
I've kept the original mtd partitioning that Netgear uses.

Buttons/LED:
Both buttons are working properly. Two leds are not enabled: The red internet led is connected to the pci_gnt1 pin... I can't disable it because then DMA stops working.
The green wifi led is connected to an unknown atheros gpio.

Signed-off-by: Pieter Voorthuijsen <p.voorthuijsen at gmail.com>
SVN-Revision: 31910
target/linux/lantiq/base-files/lib/preinit/42_athfix [new file with mode: 0644]
target/linux/lantiq/files-3.3/arch/mips/lantiq/xway/mach-netgear.c