Add psplash (#2395), mark it as x86 only
authorFlorian Fainelli <florian@openwrt.org>
Sun, 16 Sep 2007 13:22:12 +0000 (13:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 16 Sep 2007 13:22:12 +0000 (13:22 +0000)
SVN-Revision: 8793

utils/psplash/Makefile [new file with mode: 0644]

diff --git a/utils/psplash/Makefile b/utils/psplash/Makefile
new file mode 100644 (file)
index 0000000..72185d2
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=psplash
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://projects.o-hand.com/sources/psplash/
+PKG_MD5SUM:=7649b7e0fac573eca2048a2a267e242b
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/psplash
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@LINUX_2_6_X86
+  TITLE:=A boot splash screen
+  DESCRIPTION:=PSplash is a userspace graphical boot splash screen.
+  URL:=http://projects.o-hand.com/psplash
+endef
+
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/psplash/install
+       $(INSTALL_DIR) $(1)/bin
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/psplash \
+               $(PKG_INSTALL_DIR)/usr/bin/psplash-write \
+               $(1)/bin/
+endef
+
+
+$(eval $(call BuildPackage,psplash))