[packages] multimedia/motion: update to 3.2.9
authorGabor Juhos <juhosg@openwrt.org>
Wed, 9 Jan 2008 20:02:34 +0000 (20:02 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 9 Jan 2008 20:02:34 +0000 (20:02 +0000)
SVN-Revision: 10155

multimedia/motion/Makefile
multimedia/motion/patches/001-ffmpeg.patch
multimedia/motion/patches/002-honor_cppflags.patch

index 7b46573aecd3c2f604c3de04fc424e3c73ad294a..eb45d1f2ff5d11fdfd311564359632445c9b39c2 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=motion
-PKG_VERSION:=20070331-051001
+PKG_VERSION:=3.2.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
                @SF/motion
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lavrsen.dk/sources/motion-daily \
                @SF/motion
-PKG_MD5SUM:=16e58186022dfee1c0dcaf03cf5393e5
+PKG_MD5SUM:=6003011b126c9b17e23e085e7fba6536
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -43,13 +43,13 @@ define Build/Configure
        )
 endef
 
        )
 endef
 
-define Build/Compile   
+define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
-define Package/motion/install  
+define Package/motion/install
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/etc
        $(CP) $(PKG_INSTALL_DIR)/etc/motion-dist.conf $(1)/etc/motion.conf
        $(INSTALL_DIR) $(1)/usr/bin
index 50c57484ccebeb1962d96ecbb444fe3f3f87c290..a56201e733d55fe004f2216f1f209eb383dd0f4b 100644 (file)
@@ -1,7 +1,8 @@
-diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
---- motion-3.2.8.old/motion.c  2007-03-31 12:54:31.000000000 +0200
-+++ motion-3.2.8/motion.c      2007-03-31 13:08:27.000000000 +0200
-@@ -1282,6 +1282,7 @@
+Index: motion-3.2.9/motion.c
+===================================================================
+--- motion-3.2.9.orig/motion.c
++++ motion-3.2.9/motion.c
+@@ -1285,6 +1285,7 @@ static void *motion_loop(void *arg)
                 * httpd-control snaps are always enabled.
                 */
  
                 * httpd-control snaps are always enabled.
                 */
  
@@ -9,7 +10,7 @@ diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
                /* time_current_frame is used both for snapshot and timelapse features */
                time_current_frame = cnt->currenttime;
  
                /* time_current_frame is used both for snapshot and timelapse features */
                time_current_frame = cnt->currenttime;
  
-@@ -1291,7 +1292,7 @@
+@@ -1294,7 +1295,7 @@ static void *motion_loop(void *arg)
                        event(cnt, EVENT_IMAGE_SNAPSHOT, newimg, NULL, NULL, cnt->currenttime_tm);
                        cnt->snapshot = 0;
                }
                        event(cnt, EVENT_IMAGE_SNAPSHOT, newimg, NULL, NULL, cnt->currenttime_tm);
                        cnt->snapshot = 0;
                }
@@ -18,7 +19,7 @@ diff -x .svn -ruN motion-3.2.8.old/motion.c motion-3.2.8/motion.c
  
        /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
  
  
        /***** MOTION LOOP - TIMELAPSE FEATURE SECTION *****/
  
-@@ -1366,9 +1367,9 @@
+@@ -1369,9 +1370,9 @@ static void *motion_loop(void *arg)
                        event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
  
  
                        event(cnt, EVENT_TIMELAPSEEND, NULL, NULL, NULL, cnt->currenttime_tm);
  
  
index 322fb772d35f677d857ca673db60a5f7f5e1c646..cf6979eedf4152db3c99e767e68c362bfcd28026 100644 (file)
@@ -1,7 +1,8 @@
-diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
---- motion-3.2.5.1-old/Makefile.in     2006-03-07 22:52:49.000000000 +0100
-+++ motion-3.2.5.1-new/Makefile.in     2006-03-27 22:04:34.000000000 +0200
-@@ -32,6 +32,7 @@
+Index: motion-3.2.9/Makefile.in
+===================================================================
+--- motion-3.2.9.orig/Makefile.in
++++ motion-3.2.9/Makefile.in
+@@ -33,6 +33,7 @@ examplesdir = $(docdir)/examples
  ################################################################################
  CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
               -Dsysconfdir=\"$(sysconfdir)\"
  ################################################################################
  CFLAGS       = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
               -Dsysconfdir=\"$(sysconfdir)\"
@@ -9,7 +10,7 @@ diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
  LDFLAGS      = @LDFLAGS@
  LIBS         = @LIBS@ 
  VIDEO_OBJ    = @VIDEO@
  LDFLAGS      = @LDFLAGS@
  LIBS         = @LIBS@ 
  VIDEO_OBJ    = @VIDEO@
-@@ -115,7 +116,7 @@
+@@ -120,7 +121,7 @@ endif
  ################################################################################
  $(DEPEND_FILE): *.h $(SRC)
        @echo "Generating dependencies, please wait..."
  ################################################################################
  $(DEPEND_FILE): *.h $(SRC)
        @echo "Generating dependencies, please wait..."