replace sdcc prereq check with a simple command test
authorFelix Fietkau <nbd@openwrt.org>
Sun, 21 Jan 2007 01:13:44 +0000 (01:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 21 Jan 2007 01:13:44 +0000 (01:13 +0000)
SVN-Revision: 6152

utils/firmwarehotplug/Makefile

index cff3be1c1415b37267ed4daec6ea6c2fc6ca82ad..501151739800dc283435aa801604605f59fb320b 100644 (file)
@@ -49,17 +49,6 @@ endef
 
 $(eval $(call BuildPackage,firmwarehotplug))
 
-define Require/working-sdcc
-       echo 'int main() { return 0; }' >$(TMP_DIR)/a.c; \
-       sdcc -o $(TMP_DIR)/a.out $(TMP_DIR)/a.c && { \
-               rm -f $(TMP_DIR)/a.* \
-       } || { \
-               rm -f $(TMP_DIR)/a.*; \
-               false \
-       }
-
-endef
-
-$(eval $(call Require,working-sdcc, \
+$(eval $(call RequireCommand,sdcc, \
         Please install the SDCC Cross Compiler (sdcc). \
 ))