update wireless-tools to v0.29 (final), refresh patch, bumb release number
authorNicolas Thill <nico@openwrt.org>
Tue, 27 Jan 2009 15:15:42 +0000 (15:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 27 Jan 2009 15:15:42 +0000 (15:15 +0000)
SVN-Revision: 14221

package/wireless-tools/Makefile
package/wireless-tools/patches/001-debian.patch

index ceae0f1f8acec3ced6ea02dc52ac4498525f80fb..f3009252083801fc867584ac236196f0bdc39a76 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wireless-tools
 PKG_VERSION:=29
-PKG_MINOR:=.pre21
-PKG_RELEASE:=2
+PKG_MINOR:=
+PKG_RELEASE:=3
 
 PKG_SOURCE:=wireless_tools.$(PKG_VERSION)$(PKG_MINOR).tar.gz
 PKG_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
-PKG_MD5SUM:=953774d6a34050bae4ef3bfa731f6653
+PKG_MD5SUM:=e06c222e186f7cc013fd272d023710cb
 TAR_OPTIONS += || true
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/wireless_tools.$(PKG_VERSION)
index 1d9c78eb2ddbce7cb4d02058124fea5b173a9a27..e00bad279bea50578fa82bb48651414463072b40 100644 (file)
@@ -1,8 +1,6 @@
-Index: wireless_tools.29/iwlib.c
-===================================================================
---- wireless_tools.29.orig/iwlib.c     2007-06-04 13:22:18.700012448 +0200
-+++ wireless_tools.29/iwlib.c  2007-06-04 13:22:18.773001352 +0200
-@@ -667,6 +667,7 @@
+--- a/iwlib.c
++++ b/iwlib.c
+@@ -667,6 +667,7 @@ iw_get_basic_config(int                    skfd,
  {
    struct iwreq                wrq;
  
@@ -10,11 +8,9 @@ Index: wireless_tools.29/iwlib.c
    memset((char *) info, 0, sizeof(struct wireless_config));
  
    /* Get wireless name */
-Index: wireless_tools.29/Makefile
-===================================================================
---- wireless_tools.29.orig/Makefile    2007-06-04 13:22:18.707011384 +0200
-+++ wireless_tools.29/Makefile 2007-06-04 13:22:18.774001200 +0200
-@@ -73,8 +73,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -73,8 +73,8 @@ DYNAMIC_LINK= libiw.so
  # Install directories
  INSTALL_DIR= $(PREFIX)/sbin/
  INSTALL_LIB= $(PREFIX)/lib/
@@ -25,7 +21,7 @@ Index: wireless_tools.29/Makefile
  
  # Various commands
  RM = rm -f
-@@ -102,9 +102,9 @@
+@@ -102,9 +102,9 @@ ifdef BUILD_WE_ESSENTIAL
  endif
  
  # Other flags