[package] comgt: handle ttyHS* devices in usb hotplug, fix typo (#9046)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Mar 2011 09:09:05 +0000 (09:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 15 Mar 2011 09:09:05 +0000 (09:09 +0000)
SVN-Revision: 26175

package/comgt/Makefile
package/comgt/files/3g.usb

index c3cf8ed1b53a88830e0f6c44d1ce9f5169674411..7c120cb50db8d19f78fc4cdb1cf05b9b600926ab 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index ecaa96f85b153c584497d1467fcffb7b8a42006c..d5a38b8a4ccfdd38723bd89c3cb1c194f0414626 100644 (file)
@@ -36,7 +36,7 @@ if [ "$ACTION" = add ]; then
        esac
 
        local tty
        esac
 
        local tty
-       for tty in /sys/$DEVPATH/ttyUSB* /sys/$DEVPATH/tty/ttyACM*;; do
+       for tty in /sys/$DEVPATH/ttyUSB* /sys/$DEVPATH/tty/ttyACM* /sys/$DEVPATH/tty/ttyHS*; do
                [ -d "$tty" ] || continue
                config_foreach find_3g_iface interface "$tty"
        done
                [ -d "$tty" ] || continue
                config_foreach find_3g_iface interface "$tty"
        done