[Packages] libs/pcre: Update to 7.6
authorOliver Ertl <oliver@ertl-net.net>
Sat, 16 Feb 2008 10:39:38 +0000 (10:39 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Sat, 16 Feb 2008 10:39:38 +0000 (10:39 +0000)
SVN-Revision: 10467

libs/pcre/Makefile
libs/pcre/patches/750-pcre_config_cross.patch

index d968ca7940c149b7713e0213173923757855c5b8..ab43d9cf009bdd8f7bdedda843ca965f318a5f04 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcre
-PKG_VERSION:=7.2
+PKG_VERSION:=7.6
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/pcre
-PKG_MD5SUM:=53305db73855f1ff155dcd2c05d448d3
+PKG_MD5SUM:=2af38e083fb90ef60fa9eda7cc290e86
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,12 +31,12 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
        --enable-utf8 \
-       --disable-cpp
+       --disable-cpp \
 
 MAKE_FLAGS += \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(TARGET_CFLAGS)" \
-       all
+       all \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib
index 192da90e3c0ff744823359f2c5337c3737eecdfd..a4b85bd8ebc27065b61961c75ecb89f69ba17a6c 100644 (file)
@@ -1,7 +1,7 @@
-Index: pcre-7.2/pcre-config.in
+Index: pcre-7.6/pcre-config.in
 ===================================================================
---- pcre-7.2.orig/pcre-config.in       2007-07-16 08:33:37.000000000 +0200
-+++ pcre-7.2/pcre-config.in    2007-07-16 08:33:37.000000000 +0200
+--- pcre-7.6.orig/pcre-config.in       2008-02-16 11:13:56.000000000 +0100
++++ pcre-7.6/pcre-config.in    2008-02-16 11:13:57.000000000 +0100
 @@ -21,6 +21,10 @@
    libR=" -Wl,-R@libdir@"
    ;;