AA: backport r36655 from trunk
authorSteven Barth <cyrus@openwrt.org>
Fri, 24 May 2013 15:11:24 +0000 (15:11 +0000)
committerSteven Barth <cyrus@openwrt.org>
Fri, 24 May 2013 15:11:24 +0000 (15:11 +0000)
SVN-Revision: 36715

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 4ad0f37742cc9077b2cdf765d8acf8d329504a8c..baa48d579e5fee4707519967467a282afe0fc820 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.62
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 85c22c37451bd8a31f95871669ad023fe6ea734f..5d5d97fe04e26b32d66b859046d55addba7cfdce 100644 (file)
@@ -133,6 +133,9 @@ dnsmasq() {
        config_get hostsfile "$cfg" dhcphostsfile
        [ -e "$hostsfile" ] && xappend "--dhcp-hostsfile=$hostsfile"
 
+       mkdir -p /tmp/hosts
+       xappend "--addn-hosts=/tmp/hosts"
+
        local rebind
        config_get_bool rebind "$cfg" rebind_protection 1
        [ $rebind -gt 0 ] && {