[uml] replace unfortify patch with a better one
authorFlorian Fainelli <florian@openwrt.org>
Mon, 13 Jun 2011 12:45:12 +0000 (12:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Mon, 13 Jun 2011 12:45:12 +0000 (12:45 +0000)
Thanks to Richard Weinberger for providing this patch

SVN-Revision: 27168

target/linux/uml/patches-2.6.39/002-export___sprintf_chk.patch [new file with mode: 0644]
target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch [deleted file]

diff --git a/target/linux/uml/patches-2.6.39/002-export___sprintf_chk.patch b/target/linux/uml/patches-2.6.39/002-export___sprintf_chk.patch
new file mode 100644 (file)
index 0000000..1d3cf49
--- /dev/null
@@ -0,0 +1,14 @@
+diff --git a/arch/um/os-Linux/user_syms.c b/arch/um/os-Linux/user_syms.c
+index 05f5ea8..9e71e7e 100644
+--- a/arch/um/os-Linux/user_syms.c
++++ b/arch/um/os-Linux/user_syms.c
+@@ -18,6 +18,9 @@ extern void *memmove(void *, const void *, size_t);
+ extern void *memset(void *, int, size_t);
+ extern int printf(const char *, ...);
++extern int __sprintf_chk(char *str, int flag, size_t strlen, const char *format);
++EXPORT_SYMBOL(__sprintf_chk);
++
+ /* If it's not defined, the export is included in lib/string.c.*/
+ #ifdef __HAVE_ARCH_STRSTR
+ EXPORT_SYMBOL(strstr);
diff --git a/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch b/target/linux/uml/patches-2.6.39/002-gcc4_unfortify_source.patch
deleted file mode 100644 (file)
index 2be33d0..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/arch/um/Makefile-i386
-+++ b/arch/um/Makefile-i386
-@@ -39,4 +39,8 @@ KBUILD_CFLAGS += $(shell if [ $(call cc-
-                       echo $(call cc-option,-fno-unit-at-a-time); \
-                       else echo $(call cc-option,-funit-at-a-time); fi ;)
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)
-+
- KBUILD_CFLAGS += $(cflags-y)
---- a/arch/um/Makefile-x86_64
-+++ b/arch/um/Makefile-x86_64
-@@ -24,3 +24,7 @@ LINK-y += -m64
- # Do unit-at-a-time unconditionally on x86_64, following the host
- KBUILD_CFLAGS += $(call cc-option,-funit-at-a-time)
-+
-+# disable compile-time buffer checks, enabled by default on Ubuntu 8.10 
-+# and later
-+KBUILD_CFLAGS += $(call cc-option,-U_FORTIFY_SOURCE)