[ar71xx] experimental support for the Planex MZK-W04NU board
authorGabor Juhos <juhosg@openwrt.org>
Mon, 26 Jan 2009 18:50:43 +0000 (18:50 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 26 Jan 2009 18:50:43 +0000 (18:50 +0000)
SVN-Revision: 14208

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files-2.6.28/arch/mips/include/asm/mach-ar71xx/ar71xx.h
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w04nu.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/include/asm-mips/mach-ar71xx/ar71xx.h

index a006dd998e5d2da64136b7ae7c1d05cb486b0868..eb6b40b3f802207bbfafb72efa8b087844b35b37 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
index 337efdd10b32309bfbb86dd2cfc0678e55dd7cf9..33e22b4c9a14f5d69b66db394622c65be2b0c4a2 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
index d2c978d09e0d45c6880b8a2b5b0bb434a90256d6..f85ed654322268a01cdc96e3375e3a47f14d992f 100644 (file)
@@ -7,6 +7,7 @@ CONFIG_AG71XX=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
+CONFIG_AR71XX_MACH_MZK_W04NU=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
 CONFIG_AR71XX_MACH_MZK_W300NH=y
 CONFIG_AR71XX_MACH_PB42=y
 CONFIG_AR71XX_MACH_RB_4XX=y
index 64f19bf62c72eabddfc95b8151ec7f5a1ee6d24b..5aba593e290f79a71b839cccf681842f73654378 100644 (file)
@@ -1,7 +1,7 @@
 /*
  *  Atheros AR71xx SoC specific definitions
  *
 /*
  *  Atheros AR71xx SoC specific definitions
  *
- *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
  *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
  *
  *  Parts of this file are based on Atheros' 2.6.15 BSP
  *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
  *
  *  Parts of this file are based on Atheros' 2.6.15 BSP
@@ -122,6 +122,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
 #define AR71XX_MACH_PB42       12      /* Atheros PB42 */
 #define AR71XX_MACH_MZK_W300NH 13      /* Planex MZK-W300NH */
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
 #define AR71XX_MACH_PB42       12      /* Atheros PB42 */
 #define AR71XX_MACH_MZK_W300NH 13      /* Planex MZK-W300NH */
+#define AR71XX_MACH_MZK_W04NU  14      /* Planex MZK-W04NU */
 
 /*
  * PLL block
 
 /*
  * PLL block
index cd2624cc66b48419b0e6b01493313de01f122255..ed7be96abc2a3d575f53f872f4fc520cf131b387 100644 (file)
@@ -35,6 +35,10 @@ config AR71XX_MACH_WNR2000
        bool "NETGEAR WNR2000 board support"
        default y
 
        bool "NETGEAR WNR2000 board support"
        default y
 
+config AR71XX_MACH_MZK_W04NU
+       bool "Planex MZK-W04NU board support"
+       default y
+
 config AR71XX_MACH_MZK_W300NH
        bool "Planex MZK-W300NH board support"
        default y
 config AR71XX_MACH_MZK_W300NH
        bool "Planex MZK-W300NH board support"
        default y
index 33118d77410924bc624d83b8f3c0267ea14d0aaf..8629b33ef822af18de03873bd5c3db47c2592950 100644 (file)
@@ -13,6 +13,7 @@ obj-y := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
+obj-$(CONFIG_AR71XX_MACH_MZK_W04NU)    += mach-mzk-w04nu.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
 obj-$(CONFIG_AR71XX_MACH_PB42)         += mach-pb42.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
 obj-$(CONFIG_AR71XX_MACH_MZK_W300NH)   += mach-mzk-w300nh.o
 obj-$(CONFIG_AR71XX_MACH_PB42)         += mach-pb42.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w04nu.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-mzk-w04nu.c
new file mode 100644 (file)
index 0000000..2aeb31e
--- /dev/null
@@ -0,0 +1,94 @@
+/*
+ *  Planex MZK-W04NU board support
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/spi/spi.h>
+#include <linux/spi/flash.h>
+
+#include <asm/mips_machine.h>
+
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/platform.h>
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition mzk_w04nu_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x040000,
+               .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "u-boot-env",
+               .offset         = 0x040000,
+               .size           = 0x010000,
+       } , {
+               .name           = "uImage",
+               .offset         = 0x050000,
+               .size           = 0x160000,
+       } , {
+               .name           = "rootfs",
+               .offset         = 0x1b0000,
+               .size           = 0x610000,
+       } , {
+               .name           = "config",
+               .offset         = 0x7c0000,
+               .size           = 0x020000,
+       } , {
+               .name           = "art",
+               .offset         = 0x7e0000,
+               .size           = 0x020000,
+               .mask_flags     = MTD_WRITEABLE,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct flash_platform_data mzk_w04nu_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+        .parts          = mzk_w04nu_partitions,
+        .nr_parts       = ARRAY_SIZE(mzk_w04nu_partitions),
+#endif
+};
+
+static struct spi_board_info mzk_w04nu_spi_info[] = {
+       {
+               .bus_num        = 0,
+               .chip_select    = 0,
+               .max_speed_hz   = 25000000,
+               .modalias       = "m25p80",
+               .platform_data  = &mzk_w04nu_flash_data,
+       }
+};
+
+static void __init mzk_w04nu_setup(void)
+{
+       ar71xx_add_device_mdio(0x0);
+
+       ar71xx_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth0_data.phy_mask = 0xf;
+       ar71xx_eth0_data.speed = SPEED_100;
+       ar71xx_eth0_data.duplex = DUPLEX_FULL;
+
+       ar71xx_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_RMII;
+       ar71xx_eth1_data.phy_mask = 0x10;
+
+       ar71xx_add_device_eth(0);
+       ar71xx_add_device_eth(1);
+
+       ar71xx_add_device_spi(NULL, mzk_w04nu_spi_info,
+                                       ARRAY_SIZE(mzk_w04nu_spi_info));
+
+       ar71xx_add_device_usb();
+
+       ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_MZK_W04NU, "Planex MZK-W04NU", mzk_w04nu_setup);
index d05217c615f2bb40607945008e36c2500b82f65c..8e93807ae5df9e81b6bf2f55e693601c9e667989 100644 (file)
@@ -1,7 +1,7 @@
 /*
  *  Atheros AR71xx SoC specific prom routines
  *
 /*
  *  Atheros AR71xx SoC specific prom routines
  *
- *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
  *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
  *
  *  This program is free software; you can redistribute it and/or modify it
  *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
  *
  *  This program is free software; you can redistribute it and/or modify it
@@ -67,6 +67,9 @@ static struct board_rec boards[] __initdata = {
        }, {
                .name           = "MZK-W300NH",
                .mach_type      = AR71XX_MACH_MZK_W300NH,
        }, {
                .name           = "MZK-W300NH",
                .mach_type      = AR71XX_MACH_MZK_W300NH,
+       }, {
+               .name           = "MZK-W04NU",
+               .mach_type      = AR71XX_MACH_MZK_W04NU,
        }
 };
 
        }
 };
 
index 64f19bf62c72eabddfc95b8151ec7f5a1ee6d24b..5aba593e290f79a71b839cccf681842f73654378 100644 (file)
@@ -1,7 +1,7 @@
 /*
  *  Atheros AR71xx SoC specific definitions
  *
 /*
  *  Atheros AR71xx SoC specific definitions
  *
- *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
  *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
  *
  *  Parts of this file are based on Atheros' 2.6.15 BSP
  *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
  *
  *  Parts of this file are based on Atheros' 2.6.15 BSP
@@ -122,6 +122,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
 #define AR71XX_MACH_PB42       12      /* Atheros PB42 */
 #define AR71XX_MACH_MZK_W300NH 13      /* Planex MZK-W300NH */
 #define AR71XX_MACH_WNR2000    11      /* NETGEAR WNR2000 */
 #define AR71XX_MACH_PB42       12      /* Atheros PB42 */
 #define AR71XX_MACH_MZK_W300NH 13      /* Planex MZK-W300NH */
+#define AR71XX_MACH_MZK_W04NU  14      /* Planex MZK-W04NU */
 
 /*
  * PLL block
 
 /*
  * PLL block