packages: Update libspeex to 1.2beta3
authorAndy Boyett <agb@openwrt.org>
Thu, 3 Jan 2008 23:10:21 +0000 (23:10 +0000)
committerAndy Boyett <agb@openwrt.org>
Thu, 3 Jan 2008 23:10:21 +0000 (23:10 +0000)
Signed-off-by: Alfred E. Heggestad <aeh@db.org>
SVN-Revision: 10101

libs/speex/Makefile
libs/speex/patches/100-compile_fix.patch [deleted file]

index 733251c18424976de4d99ee1bfca54c87da24d8a..d7b0a22379f544f789caaa99c7ba7ff5276e21a8 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=speex
-PKG_VERSION:=1.2beta1
+PKG_VERSION:=1.2beta3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.us.xiph.org/releases/speex/
-PKG_MD5SUM:=aac2e4ba42122b885c787ea280acb3d9
+PKG_MD5SUM:=bcada04dc663a725ee7fcfa6301520a3
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
@@ -37,7 +37,7 @@ define Package/libspeex/description
        alternative to expensive proprietary speech codecs. Moreover, Speex 
        is well-adapted to Internet applications and provides useful features 
        that are not present in most other codecs.
        alternative to expensive proprietary speech codecs. Moreover, Speex 
        is well-adapted to Internet applications and provides useful features 
        that are not present in most other codecs.
-       
+
        This package contains the shared codec library, needed by other programs.
 endef
 
        This package contains the shared codec library, needed by other programs.
 endef
 
@@ -49,6 +49,8 @@ define Build/Configure
                --enable-static \
                --enable-fixed-point \
                --disable-oggtest \
                --enable-static \
                --enable-fixed-point \
                --disable-oggtest \
+               --disable-float-api \
+               --disable-vbr \
        )
 endef
 
        )
 endef
 
diff --git a/libs/speex/patches/100-compile_fix.patch b/libs/speex/patches/100-compile_fix.patch
deleted file mode 100644 (file)
index 42a848d..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Binary files speex-1.1.12.orig/libspeex/.Makefile.in.swp and speex-1.1.12/libspeex/.Makefile.in.swp differ
-diff -urN speex-1.1.12.orig/libspeex/Makefile.in speex-1.1.12/libspeex/Makefile.in
---- speex-1.1.12.orig/libspeex/Makefile.in     2007-05-13 13:18:43.000000000 +0200
-+++ speex-1.1.12/libspeex/Makefile.in  2007-05-13 13:19:08.000000000 +0200
-@@ -245,7 +245,7 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
- EXTRA_DIST = testenc.c testenc_wb.c testenc_uwb.c testdenoise.c testecho.c
--INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir) @OGG_CFLAGS@
-+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include -I$(top_builddir)
- lib_LTLIBRARIES = libspeex.la
- # Sources for compilation in the library