[buildroot] add support for darcs repositories
authorFlorian Fainelli <florian@openwrt.org>
Sun, 24 Oct 2010 12:36:44 +0000 (12:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 24 Oct 2010 12:36:44 +0000 (12:36 +0000)
This patch adds support for darcs repositories (as sources of packages).

It does *not* add support for darcs:// URI scheme because such a scheme
do not exist (AFAIK).  You must therefore manually set PKG_SOURCE_PROTO
to darcs in your Makefile (and use a regular http:// URI). You also have
to set PKG_SOURCE_VERSION to a string matching a tag contained in the
repository, and PKG_SOURCE_SUBDIR to something sensible
($(PACKAGE_NAME)-$(PACKAGE_SOURCE_VERSION) for instance).

Same rationale as for the previous patch ("useless to most, but small
and straightforward so why no add it?).

Best regards,

Signed-off-by: Gabriel Kerneis <kerneis@pps.jussieu.fr>
SVN-Revision: 23615

include/download.mk

index 9dd26a7447232b505e776629ebf3c490b05e8ed2..a2238bce599ddc8d9b9d6c8b6ec973cd64620e0a 100644 (file)
@@ -28,7 +28,7 @@ $(strip \
 )
 endef
 
 )
 endef
 
-# code for creating tarballs from cvs/svn/git/bzr/hg checkouts - useful for mirror support
+# code for creating tarballs from cvs/svn/git/bzr/hg/darcs checkouts - useful for mirror support
 dl_pack/bz2=$(TAR) cfj $(1) $(2)
 dl_pack/gz=$(TAR) cfz $(1) $(2)
 dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
 dl_pack/bz2=$(TAR) cfj $(1) $(2)
 dl_pack/gz=$(TAR) cfz $(1) $(2)
 dl_pack/unknown=echo "ERROR: Unknown pack format for file $(1)"; false
@@ -128,11 +128,28 @@ define DownloadMethod/hg
        )
 endef
 
        )
 endef
 
+define DownloadMethod/darcs
+       $(call wrap_mirror, \
+               echo "Checking out files from the darcs repository..."; \
+               mkdir -p $(TMP_DIR)/dl && \
+               cd $(TMP_DIR)/dl && \
+               rm -rf $(SUBDIR) && \
+               [ \! -d $(SUBDIR) ] && \
+               darcs get -t $(VERSION) $(URL) $(SUBDIR) && \
+               find $(SUBDIR) -name _darcs | xargs rm -rf && \
+               echo "Packing checkout..." && \
+               $(call dl_pack,$(TMP_DIR)/dl/$(FILE),$(SUBDIR)) && \
+               mv $(TMP_DIR)/dl/$(FILE) $(DL_DIR)/ && \
+               rm -rf $(SUBDIR); \
+       )
+endef
+
 Validate/cvs=VERSION SUBDIR
 Validate/svn=VERSION SUBDIR
 Validate/git=VERSION SUBDIR
 Validate/bzr=VERSION SUBDIR
 Validate/hg=VERSION SUBDIR
 Validate/cvs=VERSION SUBDIR
 Validate/svn=VERSION SUBDIR
 Validate/git=VERSION SUBDIR
 Validate/bzr=VERSION SUBDIR
 Validate/hg=VERSION SUBDIR
+Validate/darcs=VERSION SUBDIR
 
 define Download/Defaults
   URL:=
 
 define Download/Defaults
   URL:=