change from /jffs to /overlay, patch from Daniel Dickinson
authorFlorian Fainelli <florian@openwrt.org>
Sun, 21 Mar 2010 17:16:50 +0000 (17:16 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 21 Mar 2010 17:16:50 +0000 (17:16 +0000)
SVN-Revision: 20356

16 files changed:
include/image.mk
package/base-files/Makefile
package/base-files/files/lib/firstboot/20_no_fo_mount_jffs
package/base-files/files/lib/firstboot/30_is_rootfs_mounted
package/base-files/files/lib/firstboot/30_no_fo_pivot
package/base-files/files/lib/firstboot/40_copy_ramoverlay
package/base-files/files/lib/firstboot/50_pivot
package/base-files/files/lib/firstboot/99_10_no_fo_cleanup
package/base-files/files/lib/functions/boot.sh
package/base-files/files/lib/preinit/40_mount_jffs2
package/base-files/files/lib/preinit/70_pivot_jffs2_root
package/base-files/files/lib/upgrade/common.sh
package/base-files/files/sbin/firstboot
package/block-extroot/files/50_determine_usb_root
package/block-extroot/files/60_pivot_usb_root
package/opkg/files/opkg.conf

index 47871f9541aa1bd475a195555ccdf990e28345ac..0ce6336cc597f75a8dcf80ae3cb3a1dd2c3b5edc 100644 (file)
@@ -62,14 +62,13 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                $(call Image/Build,jffs2-$(1))
     endef
     define Image/mkfs/jffs2
-               rm -rf $(TARGET_DIR)/jffs
                $(foreach SZ,$(JFFS2_BLOCKSIZE),$(call Image/mkfs/jffs2/sub,$(SZ)))
     endef
   endif
 
   ifeq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),y)
     define Image/mkfs/squashfs
-               @mkdir -p $(TARGET_DIR)/jffs
+               @mkdir -p $(TARGET_DIR)/overlay
                $(MKSQUASHFS_CMD) $(TARGET_DIR) $(KDIR)/root.squashfs -nopad -noappend -root-owned $(SQUASHFS_OPTS)
                $(call Image/Build,squashfs)
     endef
index 0d4c29eec887b1ae9d1adc2beeb6ae99be5e1be3..88ab6101872f34d399a5193f9b76e3029b0e63e4 100644 (file)
@@ -364,7 +364,7 @@ define Package/base-files/install
        mkdir -p $(1)/dev
        mkdir -p $(1)/etc/crontabs
        mkdir -p $(1)/etc/rc.d
-       mkdir -p $(1)/jffs
+       mkdir -p $(1)/overlay
        mkdir -p $(1)/lib/firmware
        $(if $(LIB_SUFFIX),-ln -s lib $(1)/lib$(LIB_SUFFIX))
        mkdir -p $(1)/mnt
index da914b143fc56f400860e5f3487ca40e01d16c6b..8a1d4e06d230635fa4e935d299c6cfb57627c440 100644 (file)
@@ -5,11 +5,11 @@
 
 no_fo_mount_jffs() {
     # initialize jffs2
-    mount "$mtdpart" /jffs -t jffs2 || exit
+    mount "$mtdpart" /overlay -t jffs2 || exit
     
     # workaround to ensure that union can attach properly
     sync
-    ls /jffs >/dev/null
+    ls /overlay >/dev/null
 }
 
 boot_hook_add no_fo no_fo_mount_jffs
index 7c3fe6c4c83f3607a4fc9172ebbe64d6bb3c915a..e2ba01d502e153c58b7ea4df344cd7f13c13ab77 100644 (file)
@@ -4,7 +4,7 @@
 # Copyright (C) 2010 Vertical Communications
 
 skip_if_rootfs_mounted() {
-    mount "$mtdpart" /rom/jffs -t jffs2 || exit
+    mount "$mtdpart" /rom/overlay -t jffs2 || exit
 }
 
 boot_hook_add switch2jffs skip_if_rootfs_mounted
index cb82cde5dd0af08069977b3b42574bc486e5fa37..b5c2601ee8d5f78a0556fcf24c9e298187888b92 100644 (file)
@@ -5,7 +5,7 @@
 
 no_fo_pivot() {
     # switch to the new (empty) jffs2
-    fopivot /jffs /rom 1
+    fopivot /overlay /rom 1
 }
 
 boot_hook_add no_fo no_fo_pivot
index 4b6a8828f0363b682c22f3019d13ff431b567217..39c2edacba15260d8b511e186be5c59aebd2b625 100644 (file)
@@ -8,7 +8,7 @@ copy_ramoverlay() {
     mount -o remount,ro none / 2>&-
     # copy ramoverlay to jffs2
     echo -n "copying files ... "
-    cp -a /tmp/root/* /rom/jffs 2>&-
+    cp -a /tmp/root/* /rom/overlay 2>&-
     echo "done"
 }
 
index fa1c7b540024e9eccb21c9634333a3955cd21fb4..53801d7a8f82ecd8c730125fafb52be98f395ba0 100644 (file)
@@ -9,9 +9,9 @@ with_fo_pivot() {
     pivot /rom /mnt
     mount -o move /mnt /tmp/root
 
-    # /jffs is the overlay
+    # /overlay is the overlay
     # /rom is the readonly
-    fopivot /jffs /rom
+    fopivot /overlay /rom
 }
 
 boot_hook_add switch2jffs with_fo_pivot
index 5eddfb14f83d5e0a11c62501bfacee6433bcb3e4..6dedcb1e876eac2a69cea70d027db862daa336fa 100644 (file)
@@ -5,7 +5,7 @@
 
 no_fo_cleanup() {
     echo "done"
-    umount -l /jffs
+    umount -l /overlay
     umount -l /tmp/root
     exit 0
 }
index 96c1c59db2e779c47dfbf887855c6bbeb56f49fa..e6f6633adb94123c45e45a652ed753f650e57e89 100644 (file)
@@ -42,7 +42,7 @@ dupe() { # <new_root> <old_root>
        {
                cd $2 
                find . -xdev -type d
-               echo "./dev ./jffs ./mnt ./proc ./tmp"
+               echo "./dev ./overlay ./mnt ./proc ./tmp"
                # xdev skips mounted directories
                cd $1 
        } | xargs mkdir -p
@@ -69,7 +69,6 @@ pivot() { # <new_root> <old_root>
                mount -o move $2/dev /dev
                mount -o move $2/tmp /tmp
                mount -o move $2/sys /sys 2>&-
-               mount -o move $2/jffs /jffs 2>&-
                mount -o move $2/overlay /overlay 2>&-
                return 0
        }
index 99fe262c68620505f5c9c30aa426049af0fbe50e..cb743ea75cc9861f28ca6f25339a2992a8d5ac45 100644 (file)
@@ -3,7 +3,8 @@
 # Copyright (C) 2010 Vertical Communications
 
 find_mount_jffs2() {
-    mount "$(find_mtd_part rootfs_data)" /jffs -t jffs2
+       mkdir -p /tmp/overlay
+    mount "$(find_mtd_part rootfs_data)" /tmp/overlay -t jffs2
 }
 
 jffs2_not_mounted() {
index f0a2a5569aad7dfeda42bc53e6dec3655a590237..821bfb14f3c18435d4ccfda9789f50cd47b10b77 100644 (file)
@@ -5,7 +5,8 @@
 rootfs_pivot() {
     check_skip || jffs2_not_mounted || {
        echo "switching to jffs2"
-       fopivot /jffs /rom && pi_mount_skip_next=true
+       mount -o move /tmp/overlay /overlay 2>&-
+       fopivot /overlay /rom && pi_mount_skip_next=true
     }
 }
 
index 3beb6484d851f748debc1882d23123477e7d1a24..970016e7baac276d3eb595370bc0336941d697a2 100644 (file)
@@ -35,7 +35,7 @@ install_bin() { # <file> [ <symlink> ... ]
 
 pivot() { # <new_root> <old_root>
        mount | grep "on $1 type" 2>&- 1>&- || mount -o bind $1 $1
-       mkdir -p $1$2 $1/proc $1/dev $1/tmp $1/jffs && \
+       mkdir -p $1$2 $1/proc $1/dev $1/tmp $1/overlay && \
        mount -o move /proc $1/proc && \
        pivot_root $1 $1$2 || {
         umount $1 $1
@@ -43,7 +43,7 @@ pivot() { # <new_root> <old_root>
        }
        mount -o move $2/dev /dev
        mount -o move $2/tmp /tmp
-       mount -o move $2/jffs /jffs 2>&-
+       mount -o move $2/overlay /overlay 2>&-
        return 0
 }
 
@@ -63,9 +63,9 @@ run_ramfs() { # <command> [...]
        mount -o remount,ro /mnt
        umount -l /mnt
 
-       grep /jffs /proc/mounts > /dev/null && {
-               mount -o remount,ro /jffs
-               umount -l /jffs
+       grep /overlay /proc/mounts > /dev/null && {
+               mount -o remount,ro /overlay
+               umount -l /overlay
        }
 
        # spawn a new shell from ramdisk to reduce the probability of cache issues
index e9994dec3856eada1d742f946d5a9b77ba84c4d3..4da299189e7da7bb9fe5a9eaf3bc3e11601c40f8 100755 (executable)
@@ -27,8 +27,8 @@ if [ "${0##*/}" = "firstboot" ]; then
        boot_run_hook jffs2reset
     else
        mtd erase "$partname"
-       mount "$mtdpart" /jffs -t jffs2
-       fopivot /jffs /rom 1
+       mount "$mtdpart" /overlay -t jffs2
+       fopivot /overlay /rom 1
     fi
 fi
 
index 1e5f153b6a323e2fe19cb5c32e9caf39e718f873..192990c919ea5c3c1aad6e9afb0c63e9aa428de7 100644 (file)
@@ -16,8 +16,8 @@ determine_external_root() {
        # extroot requires extroot and fstab config files, therefore 
        # we assume configuration is incomplete and not to be used if either of them
        # is missing (for jffs versions of these files on squashfs image)
-       if [ "$jffs" = "/jffs" ] && [ -r "/jffs/etc/config/fstab" ]; then
-               UCI_CONFIG_DIR="/jffs/etc/config"
+       if [ "$jffs" = "/tmp/overlay" ] && [ -r "/tmp/overlay/etc/config/fstab" ]; then
+               UCI_CONFIG_DIR="/tmp/overlay/etc/config"
                ER_IS_SQUASHFS=true
        fi
 
index c8572a35fd214e75e545955e1a1abda165239f6f..1c9be97cae9b015740d1ec791fdd6fe15fdbe36a 100644 (file)
@@ -10,7 +10,7 @@ external_root_pivot() {
        check_skip || [ "$pi_extroot_mount_success" != "true" ] || {
                echo "switching to external rootfs"
                if [ "$ER_IS_SQUASHFS" = "true" ]; then
-                       umount /jffs
+                       umount /tmp/overlay
                fi
                mount -o remount,ro / && fopivot /overlay /rom && pi_mount_skip_next=true
        }
index fb61d7a470663d971595a2c9b3a9de991c08bad9..0e85936ba2c9a216a1f1231125446115c82d0bb9 100644 (file)
@@ -2,4 +2,4 @@ src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$S/packages
 dest root /
 dest ram /tmp
 lists_dir ext /var/opkg-lists
-option overlay_root /jffs
+option overlay_root /overlay