[ppc40x] increase linux partition size, and fix jffs2 images
authorGabor Juhos <juhosg@openwrt.org>
Sun, 19 Jul 2009 06:42:30 +0000 (06:42 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 19 Jul 2009 06:42:30 +0000 (06:42 +0000)
SVN-Revision: 16906

target/linux/ppc40x/image/Makefile
target/linux/ppc40x/patches-2.6.30/005-magicboxv1.patch
target/linux/ppc40x/patches-2.6.30/006-magicboxv2.patch
target/linux/ppc40x/patches/005-magicboxv1.patch
target/linux/ppc40x/patches/006-magicboxv2.patch

index b54cc06488538e9bd4a7a4cac6f6f9e6251836c1..a5be9be92affb9373f0a2f2b79ba8654759a3bdf 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-JFFS2_BLOCKSIZE=128k
+JFFS2_BLOCKSIZE=128k 64k
 
 define Image/Prepare
        cp $(LINUX_DIR)/arch/powerpc/boot/uImage $(KDIR)/uImage
@@ -28,13 +28,16 @@ define Image/Build/jffs2-128k
                dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-jffs2.img
+endef
+
+define Image/Build/jffs2-64k
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
-               dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1152k conv=sync; \
+               dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-jffs2.img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
-               dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
+               dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-jffs2.img
 endef
 
@@ -46,11 +49,11 @@ define Image/Build/squashfs
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1152k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-$(1).img
        ( \
-               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
+               dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
        ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-$(1).img
 endef
index ef29e0bf29db036e8d1b99528cde32d78e55bce1..062bbdbcebaa0970e71c340dc99dbc63047d7c8a 100644 (file)
 +                              #size-cells = <1>;
 +                              partition@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x3c0000>;
++                                      reg = <0x0 0x120000>;
 +                              };
-+                              partition@100000 {
++                              partition@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x100000 0x2c0000>;
++                                      reg = <0x120000 0x2a0000>;
 +                              };
 +                              partition@3c0000 {
 +                                      label = "u-boot";
index 8a7dbb6aef30d23e53e57b03a78c715ee4e5bb08..1fa74b8890a87132eb8066b9c17052024dba80c0 100644 (file)
 +                              #size-cells = <1>;
 +                              partition@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x3c0000>;
++                                      reg = <0x0 0x120000>;
 +                              };
-+                              partition@100000 {
++                              partition@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x100000 0x2c0000>;
++                                      reg = <0x120000 0x2a0000>;
 +                              };
 +                              partition@3c0000 {
 +                                      label = "u-boot";
index 331fc5ff19dc17644501ebd515967f4e02bb9166..582a6e833fbd0b7349484f5af6230c44ab061eeb 100644 (file)
 +                              #size-cells = <1>;
 +                              partition@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x3c0000>;
++                                      reg = <0x0 0x120000>;
 +                              };
-+                              partition@100000 {
++                              partition@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x100000 0x2c0000>;
++                                      reg = <0x120000 0x2a0000>;
 +                              };
 +                              partition@3c0000 {
 +                                      label = "u-boot";
index 33831af5d3e9f288315afa2f4b6f8170242f7b2b..8dd283faa6f1ff14cdb22275f6253a28bb2503a0 100644 (file)
 +                              #size-cells = <1>;
 +                              partition@0 {
 +                                      label = "linux";
-+                                      reg = <0x0 0x3c0000>;
++                                      reg = <0x0 0x120000>;
 +                              };
-+                              partition@100000 {
++                              partition@120000 {
 +                                      label = "rootfs";
-+                                      reg = <0x100000 0x2c0000>;
++                                      reg = <0x120000 0x2a0000>;
 +                              };
 +                              partition@3c0000 {
 +                                      label = "u-boot";