add dtc, the device tree compiler
authorImre Kaloz <kaloz@openwrt.org>
Tue, 29 Jan 2008 00:56:27 +0000 (00:56 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 29 Jan 2008 00:56:27 +0000 (00:56 +0000)
SVN-Revision: 10302

tools/Makefile
tools/dtc/Makefile [new file with mode: 0644]

index 83244fa60939b88581319b1f5f4d90c5b21c6a0b..022bbe1e9d64f2bdaa37e437c28638912c462f4d 100644 (file)
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache)
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache) dtc
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/dtc/Makefile b/tools/dtc/Makefile
new file mode 100644 (file)
index 0000000..fab6d50
--- /dev/null
@@ -0,0 +1,33 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=dtc
+PKG_VERSION:=1.1.0
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.jdl.com/software
+PKG_MD5SUM:=6c84b01f500bc989b0b1ad6138fb93d5
+PKG_CAT:=zcat
+PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dtc $(STAGING_DIR_HOST)/bin/
+endef
+
+define Build/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/dtc
+endef
+
+$(eval $(call HostBuild))