Fix alsa to mpd
authorJens Muecke <jens@nons.de>
Sun, 9 Mar 2008 22:44:26 +0000 (22:44 +0000)
committerJens Muecke <jens@nons.de>
Sun, 9 Mar 2008 22:44:26 +0000 (22:44 +0000)
Patch by Mirko Vogt <dev at nan1.de>
fix [3025]

SVN-Revision: 10581

sound/mpd/Makefile

index 7f3ac6a33739577f4b432720ec1d5b1269fb8a2e..9be7a75f34a7e52f4849f42aaa6d43384bfdc44b 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007 - 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/mpd
   SECTION:=sound
   CATEGORY:=Sound
 define Package/mpd
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread +alsa-lib
+  DEPENDS:=+libflac +libid3tag +libmad +libvorbisidec +libpthread
   TITLE:=Music Player Daemon
   URL:=http://www.musicpd.org/
 endef
   TITLE:=Music Player Daemon
   URL:=http://www.musicpd.org/
 endef
@@ -39,21 +39,19 @@ define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
 /etc/mpd.conf
 endef
 
-ifndef CONFIG_PACKAGE_kmod-soundcore
+ifndef CONFIG_PACKAGE_kmod-sound-core
        EXTRA_CONFIG_PARAM:=--disable-alsa
 endif
 
 define Build/Configure
        $(call Build/Configure/Default, \
                $(EXTRA_CONFIG_PARAM) \
        EXTRA_CONFIG_PARAM:=--disable-alsa
 endif
 
 define Build/Configure
        $(call Build/Configure/Default, \
                $(EXTRA_CONFIG_PARAM) \
-               --disable-shout \
                --disable-mod \
                --disable-audiofile \
                --disable-iconv \
                --disable-mpc \
                --disable-aac \
                --disable-mod \
                --disable-audiofile \
                --disable-iconv \
                --disable-mpc \
                --disable-aac \
-               --disable-oggvorbis \
-               --disable-oggflac \
+               --with-tremor \
                --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
                --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
                --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
                --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
                --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
                --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \