[backfire] merge r25869
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 4 Mar 2011 20:38:17 +0000 (20:38 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 4 Mar 2011 20:38:17 +0000 (20:38 +0000)
SVN-Revision: 25870

tools/bison/Makefile
tools/bison/patches/010-intl-stub-compat.patch [new file with mode: 0644]

index 16947c7d4fe5b365e99c91e23c6f04b02892f585..50d836691fd7ebeae1685ca3138a9f1a8f0a757f 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=2.3
+PKG_VERSION:=2.4.3
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=22327efdd5080e2b1acb6e560a04b43a
-PKG_CAT:=zcat
+PKG_MD5SUM:=c1d3ea81bc370dbd43b6f0b2cd21287e
+PKG_CAT:=bzcat
 
 include $(INCLUDE_DIR)/host-build.mk
 
diff --git a/tools/bison/patches/010-intl-stub-compat.patch b/tools/bison/patches/010-intl-stub-compat.patch
new file mode 100644 (file)
index 0000000..7690e10
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -57,9 +57,9 @@ main (int argc, char *argv[])
+ {
+   program_name = argv[0];
+   setlocale (LC_ALL, "");
+-  (void) bindtextdomain (PACKAGE, LOCALEDIR);
+-  (void) bindtextdomain ("bison-runtime", LOCALEDIR);
+-  (void) textdomain (PACKAGE);
++  bindtextdomain (PACKAGE, LOCALEDIR);
++  bindtextdomain ("bison-runtime", LOCALEDIR);
++  textdomain (PACKAGE);
+   uniqstrs_new ();