bluez-utils: sdpd is no longer a separate daemon.
authorRod Whitby <rod@whitby.id.au>
Sat, 30 Aug 2008 22:10:57 +0000 (22:10 +0000)
committerRod Whitby <rod@whitby.id.au>
Sat, 30 Aug 2008 22:10:57 +0000 (22:10 +0000)
SVN-Revision: 12442

utils/bluez-utils/Makefile
utils/bluez-utils/files/bluetooth.conf
utils/bluez-utils/files/bluez-utils.init

index 09e1f67f274b47b975fb45be217bcea1821b062a..3c002dcb901dc772755e47d59dd2916ff2ea0662 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
index ef55446070e1fbdaa66b2dce44a1acddd2842432..54dcec008650dfc3caa798ebe92d1fa1dcbf83bb 100644 (file)
@@ -2,9 +2,6 @@ config hcid
 #      option config   /etc/bluetooth/hcid.conf
        option enabled  1
 
-config sdpd
-       option enabled  0
-
 config rfcomm
 #      option config   /etc/bluetooth/rfcomm.conf
        option enabled  0
index 1a3227a693514a3f54d90a71d0b972479816254b..43780f5e8a56119d924dd241f409a6430c7b7f13 100644 (file)
@@ -31,15 +31,6 @@ hcid_config() {
        [ "$enabled" -gt 0 ] && /usr/sbin/hcid $args
 }
 
-sdpd_config() {
-       local cfg="$1"
-       args=""
-       append_bool "$cfg" nodaemon "-n"
-       append_bool "$cfg" something "-m"
-       config_get_bool enabled "$cfg" "enabled" '1'
-       [ "$enabled" -gt 0 ] && /usr/sbin/sdpd $args
-}
-
 rfcomm_config() {
        local cfg="$1"
        args=""
@@ -104,7 +95,6 @@ start() {
        config_load bluetooth
 
        config_foreach hcid_config hcid
-       config_foreach sdpd_config sdpd
        config_foreach rfcomm_config rfcomm
        config_foreach dund_config dund
        config_foreach pand_config pand
@@ -114,6 +104,5 @@ stop() {
        killall dund
        killall pand
        /usr/bin/rfcomm release all
-       killall sdpd
        killall hcid
 }