added sdparm and scsi-generic module, from #2481
authorJohn Crispin <john@openwrt.org>
Mon, 8 Oct 2007 21:54:13 +0000 (21:54 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 8 Oct 2007 21:54:13 +0000 (21:54 +0000)
SVN-Revision: 9201

utils/sdparm/Makefile [new file with mode: 0644]

diff --git a/utils/sdparm/Makefile b/utils/sdparm/Makefile
new file mode 100644 (file)
index 0000000..0c93dc5
--- /dev/null
@@ -0,0 +1,34 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=sdparm
+PKG_VERSION:=1.02
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://sg.torque.net/sg/p/
+PKG_MD5SUM:=cc6de6fdba91f382d00b9b8a09dd14f2
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/sdparm
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=read or modify scsi or usb disk parameters
+  DEPENDS:=+kmod-scsi-generic
+  DESCRIPTION:=\
+       The sdparm utility outputs and in some cases modifies SCSI device parameters.
+endef
+
+define Package/sdparm/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(CP) $(PKG_BUILD_DIR)/src/sdparm $(1)/usr/sbin/
+endef
+
+$(eval $(call BuildPackage,sdparm))