kernel/modules: load pppol2tp after pppox
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jul 2012 10:34:45 +0000 (10:34 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jul 2012 10:34:45 +0000 (10:34 +0000)
l2tp_ppp needs to be loaded after pppox, otherwise it ends up like this:
l2tp_ppp: Unknown symbol pppox_ioctl (err 0)
...
during boot.
I also fixed the dependency, it should be pppox rather than pppoe.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
SVN-Revision: 32562

package/kernel/modules/netsupport.mk

index 4f7c053a2607a2dbe8d7dbfbda15f1845760efe1..ca70c2568b7679887fbc6093a958c5850f8c5f01 100644 (file)
@@ -560,10 +560,10 @@ $(eval $(call KernelPackage,pptp))
 define KernelPackage/pppol2tp
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=PPPoL2TP support
-  DEPENDS:=kmod-ppp +kmod-pppoe +kmod-l2tp
+  DEPENDS:=kmod-ppp +kmod-pppox +kmod-l2tp
   KCONFIG:=CONFIG_PPPOL2TP
   FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
-  AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
+  AUTOLOAD:=$(call AutoLoad,41,l2tp_ppp)
 endef
 
 define KernelPackage/pppol2tp/description