net/smcroute: add Static Multicast Routing Daemon package (closes #8026)
authorAlexandros C. Couloumbis <alex@ozo.com>
Sun, 3 Oct 2010 10:51:15 +0000 (10:51 +0000)
committerAlexandros C. Couloumbis <alex@ozo.com>
Sun, 3 Oct 2010 10:51:15 +0000 (10:51 +0000)
SVN-Revision: 23191

net/smcroute/Makefile [new file with mode: 0644]
net/smcroute/files/smcroute.init [new file with mode: 0644]
net/smcroute/patches/001-socket_path.patch [new file with mode: 0644]
net/smcroute/patches/002-optimize_size.patch [new file with mode: 0644]

diff --git a/net/smcroute/Makefile b/net/smcroute/Makefile
new file mode 100644 (file)
index 0000000..fbd5794
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=smcroute
+PKG_VERSION:=0.92
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://www.cschill.de/smcroute
+PKG_MD5SUM:=2b50e7166606ec90e09682399e69c4a6
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/smcroute
+       SECTION:=net
+       CATEGORY:=Network
+       TITLE:=Static multicast routing daemon
+       URL:=http://www.cschill.de/smcroute/
+endef
+
+define Package/smcroute/description
+ SMCRoute is a command line tool to manipulate the multicast routes of the Linux kernel.
+endef
+
+
+ifeq ($(HOST_OS),FreeBSD)
+  TARGET_CFLAGS += -fno-builtin-log
+  TARGET_LDFLAGS += -fno-builtin-log
+endif
+
+define Build/Compile
+        $(MAKE) CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS)" -C $(PKG_BUILD_DIR)/src all
+endef
+
+define Package/smcroute/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_DIR) $(1)/etc/init.d/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/smcroute $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mcsender $(1)/usr/bin/
+       $(INSTALL_BIN) ./files/smcroute.init $(1)/etc/init.d/smcroute
+endef
+
+$(eval $(call BuildPackage,smcroute))
diff --git a/net/smcroute/files/smcroute.init b/net/smcroute/files/smcroute.init
new file mode 100644 (file)
index 0000000..3e36272
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2006-2010 OpenWrt.org
+START=50
+
+start() {
+       smcroute -d
+}
+
+stop() {
+       smcroute -k
+}
diff --git a/net/smcroute/patches/001-socket_path.patch b/net/smcroute/patches/001-socket_path.patch
new file mode 100644 (file)
index 0000000..4b6eda0
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/ipc.c        2002-07-07 19:38:49.000000000 +0200
++++ b/src/ipc.c        2010-10-01 21:44:26.000000000 +0200
+@@ -24,7 +24,7 @@
+ #include "mclab.h"
+-#define SOCKET_PATH "/var/lib/smcroute"
++#define SOCKET_PATH "/tmp/smcroute"
+ // server's listen socket
+ static int ListenSock; 
diff --git a/net/smcroute/patches/002-optimize_size.patch b/net/smcroute/patches/002-optimize_size.patch
new file mode 100644 (file)
index 0000000..23059fa
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -1,9 +1,6 @@
+ BINDIR=../bin
+-# CFLAGS=-g
+-CFLAGS=-O
+-
+ default : build.h smcroute
+ all   : smcroute mcsender